четверг, 7 марта 2013 г.

Установка Google Music Manager в openSUSE

Испробовано на версиях oS 12.1 - 12.3 x64. Собственно установка очень проста, но имеет пару затруднений:
  1. google-musicmanager-beta-1.0.55.7425 требует наличия какого-то qtwebkit.
  2. Используя PackageKit и ему подобных, требование это невозможно проигнорировать. Apper в этом случае информирует о том, что не может установить требуемые зависимости и остаётся только "Закрыть".
Устанавливать нужно с помощью zypper, либо rpm с игнорированием зависимости:
sudo zypper in Программное\ обеспечение/Linux/google-musicmanager-beta_current_x86_64.rpm 
root's password:
Загрузка данных о репозиториях...
Чтение установленных пакетов...
Разрешение зависимостей пакетов...

Проблема: ничто не предоставляет qtwebkit, необходимый для google-musicmanager-beta-1.0.55.7425-0.x86_64
 Решение 1: не устанавливать google-musicmanager-beta-1.0.55.7425-0.x86_64
 Решение 2: повредить google-musicmanager-beta-1.0.55.7425-0.x86_64, игнорируя некоторые из его зависимостей

Выберите по номеру одно из вышеуказанных решений или отмените [1/2/c] (c): 2
Разрешение зависимостей...
Разрешение зависимостей пакетов...

Будет установлен следующий НОВЫЙ пакет:
  google-musicmanager-beta 

1 новый пакет для установки.
Полный размер загрузки: 4,1 MiB. После этой операции будет использовано дополнительно 11,5 MiB.
Продолжить? [y/n/?] (y): 
Получение пакет google-musicmanager-beta-1.0.55.7425-0.x86_64             (1/1),   4,1 MiB ( 11,5 MiB после распаковки)
(1/1) Установка: google-musicmanager-beta-1.0.55.7425-0 .......................................................[готово]
Дополнительный вывод rpm:
warning: commands will be executed using /bin/sh
job 4 at 2013-03-08 02:49

2 комментария:

  1. libQtWebKit4 у нас, а qtwebkit у федорки и производных :(

    ОтветитьУдалить
    Ответы
    1. Полезная информация. Надо будет пожаловаться, когда сервис будет легален для нас.

      Удалить